import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"id\": \"(\\w+)\"";
final String string = "{\n"
+ " \"context\": {\n"
+ " \"requestId\": \"\",\n"
+ " \"locale\": \"\",\n"
+ " \"deviceId\": \"\",\n"
+ " \"currency\": \"\",\n"
+ " \"memberId\": 0,\n"
+ " \"cmsOrigin\":,\n"
+ " \"experiments\": {\n"
+ " \"forceByVariant\":,\n"
+ " \"forceByExperiment\": [\n"
+ " {\n"
+ " \"id\": \"test\",\n"
+ " \"variant\": \"A\"\n"
+ " },\n"
+ " {\n"
+ " \"id\": \"test2\",\n"
+ " \"variant\": \"A\"\n"
+ " },\n"
+ " {\n"
+ " \"id\": \"test3\",\n"
+ " \"variant\": \"A\"\n"
+ " }\n"
+ " ]\n"
+ " } \n"
+ "}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}