$re = '/(/\*([^*]|[\r\n]|(\*+([^*/]|[\r\n])))*\*+/)|(//.*)/m';
$str = '// Test
/// Test
/* test
*/
public class Whatever
{
// Foos the bar
public void SomeMethod()
{
}
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);