re = /[+-]?\d*\.?\d+(?:[eE][+-]?\d+)?/m
str = 'def{{{12.197835/// -0.001172, 12.19788 7.3E-5, //+{{12.196705 -1.7E-5, 12.196647 -0.001189///}}}Def'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end