$re = '~(?<=cn=)(?!.*cn=)[^\\\\]+~';
$str = 'ou=company\\ou=country\\ou=site\\cn=office\\cn=name\\ou=pet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);