import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([A-Z]+\\d+)_([A-Z]+\\d+(?:(?=_)|[A-Z]+(?=\\d)))";
final String string = "FQC19515_TCELL001_20190319_165944.pdf\n"
+ "FQC19515_TBNK001_20190319_165944.pdf\n"
+ "FLW194640_T20NK022_20190323_131348.pdf\n"
+ "FLW194228_C1920_SOME_DEBRIS_REMOVED.pdf\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}