$re = '/@\S+/m';
$str = 'Hello @1a1a-1a1a and @2B2B2-B2 too';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);