re = /^(?:FS-[0-9a-zA-Z]+(?:-[0-9a-zA-Z]+)?|NP[0-9a-zA-Z]+)?$/m
str = 'NP123
FS-111
FS-111-222
TEST'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end