import re
regex = re.compile(r"(Never gonna ((give you up)|(let you down)|(run around and desert you)|(make you cry)|(say goodbye)|(tell a lie and hurt you)))+", flags=re.MULTILINE)
test_str = ("Never gonna give you up\n"
"Never gonna let you down\n"
"Never gonna run around and desert you\n"
"Never gonna make you cry\n"
"Never gonna say goodbye\n"
"Never gonna tell a lie and hurt you\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")