$re = '/^(?=.*\/assets\/).*\/\K.*$/m';
$str = 'https://www.example.com/assets/screenshots/this-is-an-example/2016-12-20_15-42-29.png';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);