// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([\w ]+)( \d+)?").unwrap();
let string = "Battery Bank 1
Dummy 32 Segment 1
System
Modbus 192.168.0.1 Group
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}