const regex = /\\"+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\"+', 'gm')
const str = `"import axios from \\"axios\\";\\nimport React from \\"react\\";\\nimport \\"./App.css\\";\\n\\nexport default function App() {\\n const [imgURL, setImgURL] = React.useState(\\"\\");\\n\\n async function fetchData() {\\n let response = await axios.get(\\"https://dog.ceo/api/breed/pomeranian/images/random\\");\\n setImgURL(response.data.message);\\n console.log(response.data.message);\\n }\\n\\n React.useEffect(() => {fetchData()}, []);\\n\\n return (\\n <div className=\\"App\\">\\n <h1>Returned {imgURL}</h1>\\n <img src={imgURL} alt=\\"doggo\\" />\\n </div>\\n );\\n}"`;
const subst = `"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);