use strict;
my $str = '11
12
13
14
15
16
17
18
19
20
21
22
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
998
999
1000
1001
1002
1003
1004
1005
1006
1007
1008
1009
1010
1011
1012
1188511880
1188511881
1188511882
1188511883
1188511884
1188511885
1188511886
1188511887
1188511888
1188511889
1188511890
222220
222221
222222
222223
222224
1698522
1698523
1698524
1698525
1698526
1698527
1698528
446443
446444
446445
446446
446447
446448
446449
38593856
38593857
38593858
38593859
38593860
38593861
38593862
565653
565654
565655
565656
565657
565658
565659
824824821
824824822
824824823
824824824
824824825
824824826
824824827
2121212118
2121212119
2121212120
2121212121
2121212122
2121212123
2121212124';
my $regex = qr/^(.+)\1$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}