re = /[,.-_]?[ء-یa-zA-Z0-9]+[,.-_]?/m
str = 'اصفهان، سه راه سیمین، خ سهروردی، خ رودکی، ک شهید امینی، بن بست نوید، پلاک 387'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end