$re = '/(?i)^(?!.*--).*abc.*(?:--.*)*/m';
$str = 'abc
--abc
text abc --abc --this line should match on the first occurrence of "abc"
1234abc
--abc
-- abc
-- abc
--abc
abc
aaabbbccc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);