$re = '/^.{0,200}[vV]on \K[A-Z]\S+ [A-Z]\S+/m';
$str = '1) Wandernde Inseln Eindrücke von einer Presse-Bäderfahrt an die Nordsee / Von Reinhold Zenz Die Eisenbahndirektion Münster veranstaltete in der vergangenen Woche in Verbindung mit dem Landesverkehrsverband Ostfriesland sowie den beteiligten Reedereien und Kurverwaltungen eine Pressebäderfahrt nachden ostfriesischen Inseln, WangeroOg, Spiekeroog, Langeoog und Borkum..... Von der Besatzungsmacht waren derstellvertretende Stadtkommandant, ColonelSmith, der Residentofficer von Darmstadt, Mr. Goetcheus, ferner MajorAlbrecht und Captain Walden anwesend.
2) Drückender Geldmangel Von Ernst Samhaber Im Mai hat die industrielle Erzeugungin Westdeutschland mit 105 Prozent desStandes von 1936 den höchsten Standseit Kriegsende erreicht. Der stellvertretende amerikanische OberkommissarButtenwieser schätzt sogar die deutscheErzeugung auf 130 Prozent des Jahres1936. Es wird nicht immer anerkannt,welche schwerwiegenden Probleme dieseEntwicklung aufwirft. Jeder einzelne,der Unternehmer, der Kaufmann undnicht zuletzt der Arbeitnehmer werdenaber von den dabei sich ergebenden Fragen berührt...
3) Damit wäreeine neue Nord-Süd-Verbindung durch denOdenwald von Offenbach aus über Reinheim-Fürth bis Weinheim hergestellt, die zweifellos eine gleichleibende, rentierende Fre- quenz erhalten würde. Es käme nur daraufan, die jetzt noch fehlenden 9,5 Kilometerzwischen Reichelsheim und Fürth auszu«bauen....
4) Drückender Geldmangel Von E. Samhaber Im Mai hat die industrielle Erzeugungin Westdeutschland
this works
5) Drückender Geldmangel Von Friedrich Müller Im Mai hat die industrielle Erzeugungin Westdeutschland
umlauts are fine, too.
6) Drückender Geldmangel Von Friedrich von Sachsenhausen Im Mai hat die industrielle Erzeugungin Westdeutschland
oops
7) Drückender Geldmangel Von Dr. Friedrich Müller Im Mai hat die industrielle Erzeugungin Westdeutschland
oops
8) Drückender Geldmangel Von Juan García Díaz Im Mai hat die industrielle Erzeugungin Westdeutschland
oops
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);