use strict;
my $str = '"a1" NUMBER(10,0) CONSTRAINT "ca1" NOT NULL ENABLE,
"a2" NUMBER(10,0) CONSTRAINT "ca2" NOT NULL ENABLE,
"a3" NUMBER(14,0) DEFAULT 0 CONSTRAINT "ca3" NOT NULL ENABLE,
"a4" VARCHAR2(60 CHAR),
"a5" NUMBER(10,0),
"a6" NUMBER(10,0) DEFAULT 0 CONSTRAINT "ca6" NOT NULL ENABLE,
"a7" NUMBER(5,0) DEFAULT 0 CONSTRAINT "ca7" NOT NULL ENABLE,
"a8" NUMBER(5,0) DEFAULT 0 CONSTRAINT "ca8" NOT NULL ENABLE,
"abc" TIMESTAMP (6) DEFAULT SYSDATE NOT NULL ENABLE,
"def" CHAR(3 CHAR) NOT NULL ENABLE,
"ghi" CHAR(3 CHAR) NOT NULL ENABLE,
"XML" CLOB NOT NULL ENABLE,
"jkl" CHAR(6 CHAR),
"mno" NUMBER(*,0),
"pqr" NUMBER(*,0) DEFAULT (0) NOT NULL ENABLE, ';
my $regex = qr/^(?i)\s*("?)(?>(?<colname>\w+))\1
\s+
(?:(?<type>\b\w+\b)\s*(?:\((?<typepars>(?:\w|\s|\,|\*)+)\))?)
\s*
(\bdefault\s+(?<defaultval>(\(?)(null|\w+|\'\s\')+?\)?))?
\s*
(?:(?:\bconstraint\s+(")(?<constraint_name>\w+)\9\s+)?(?<nullable>not\s+null\b)\s+enable)?
(,?)(\s*)(?-i)$/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}