package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9.-]{8,12}`)
var str = `12-34567.-82`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}