# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(https:\/\/provider\.shsp\.swisscom\.com(?:(?!(:443|:80)(\/|\s))(?:(?::)(\d*)))*(?!:443|:80))+((?!\/stable(?=\/))(\/latest(?=\/))?)*"
test_str = "({\"repository\":\"https://company.swisscom.local\",\"remoteAppUrl\":\"https://provider.shsp.swisscom.com/\",\"clientId\":\"eb922115-1e2d-4aa6-b79e-e0a02719d0ad\",\"appWebUrl\":\"\",\"subscriptionId\":\"ccf5cd8e-0a6b-4cca-8e3d-1576c4a23ae1\",\"tenantId\":\"f486778e-3f8a-4d65-9864-3762839c950e\",\"version\":\"1.61.0\",\"isWorkspaceWebApplication\":false,\"workspaceRepository\":\"https://company.swisscom.local\",\"providerInstance\":\"latest\",\"adfsLogOutUrl\":null},[\"https://provider.shsp.swisscom.com:44303/latest/scripts/init/{lcid}/SCI.js?rev=279634fa70164cc4b9465e46146ead7f\"],\"https://cdn.shsp.azureedgnet.net/scripts/sharespace.js?v=1.61.0\");"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.