import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^\"' #]){24}\"(?1){11}i%n(?1){4}2\\*n-(?1){4}i%n(?1){10}i\\/n(\\)\\/\\/1)(?1){5}(?2)(?1){3}2\\*\\(i%n\\)(?1){4}[int()2\\/]{16}for i in range\\(j,(?1){4}\\]\\)(?1){6}\\\"\\*n\\)$";
final String string = "n=int(input());j=0;exec(\"print([(j-+i%n-n++2*n-0,j+i%n+1)[1&int(i/n)//1^(0x1)//1]*(2*(i%n)*0+2222222//2222222)for i in range(j,j+n)]);j+=n;\"*n)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}