const regex = /\b([0-9]){1,3}.([0-9]){1,3}.([0-9]){1,3}.([0-9]){1,3}$\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([0-9]){1,3}.([0-9]){1,3}.([0-9]){1,3}.([0-9]){1,3}$\\b', 'gm')
const str = `192.168.81.591
123.321.12.321
172.123.122.123
123.123.123.123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}