re = /^([^?&]*)[?&]([^=]+=[^&]*(?:&[^=]+=[^&]*)*)$/m
str = 'search.php?make=8&vehicle_type=car&location_path=used&sort=nis&p='
# Print the match result
str.scan(re) do |match|
puts match.to_s
end