import re
regex = re.compile(r"\.(psd|ai|jpg|jpeg|gif)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("uis 2,5L+0,5L GRATIS.jpeg\n"
"xyla_01.psd\n"
"xtend-climb-logo.ai\n"
"X38162 Diamond BLADE.psd\n"
"X065N - 5414045990656.jpg\n"
"x-run-logo.ai\n"
"xtend-climb-logo.gif\n"
"X38162 Diamond BLADE.psd\n"
"X065N - 5414045990656.jpg\n"
"x-run-logo.ai")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")