package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<)?text(?(1)>?|>)`)
var str = `text
<text
text>
<text>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}