$re = '/(\w)a\1/';
$str = 'hah, haa, dad, dada';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);