$re = '/^[+|(|\d]?[\d|(|\s|]+[)|\s]+\d+[-|\s]+\d+/m';
$str = '(061)235-663
1(061)235-663
+1(061)235-663
+1 061 235 663';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);