re = /(?<=[<ba]se\s)href="(.*?)"/m
str = '<html><head><base href="/" /></head><body></body></html>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end