$re = '/(?:в|от)?\s*(?:\d{1,2})?\s*\b(?:янв|фев|мар|апр|ма|июн|июл|авг|сен|окт|ноя|дек)\w*\b\s*\d{4}\s*(?:г\.|года?)|(?:от|в)?\s*\d{2}\.\d{2}.\d{4}(?:г\.?)?/mu';
$str = 'Текущая строка для проверки: Оплата за выполненные работы в октябре 2019 года дог.N07/18 от 30.03.2018г. по негарантированному заказу, сч.N00290005604 от 08.11.2019, вт.ч. НДС (20%) от 12 сентября 2020 года 381,36';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;