import Foundation
let pattern = #"((25[0-5]|(2[0-4]|1\d|[1-9]|)\d)\.?\b){4}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
192.168.1.1
127.0.0.1
256.548.0.1
255.255.255.0
192.168.123.11
0.1
123.4
19864.684.1
123.123.123
123.123.260.123
0.3.0.1
226.0.5.1
255.255.255.255
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)