$re = '/^<?@?!?([0-9]+)>?$/m';
$str = '<@302390080104955904>
<@!302390080104955904>
302390080104955904
et advertising';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);