$re = '/(?<=[a-z]{2}\d{5})-TS/m';
$str = 'tr98000-TS
we98010-TS
product1-TS.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);