re = /^(?!.*Drive).*EFI.*$/m
str = 'EFI Internal Shell
EFI Hard Drive
EFI Drive
Hard Shell EFI'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end