import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#проверка ФИО\n"
+ "#https://www.bbc.co.uk/academy/ru/articles/art20170623191659259\n"
+ "#https://www.regular-expressions.info/unicode.html\n"
+ "^\n"
+ "(?!^\\s*[\\p{Pd}’'])\n"
+ "(?![\\s\\S]*[\\p{Pd}’']\\s*$)\n"
+ "(?![\\s\\S]*?’’)\n"
+ "(?![\\s\\S]*?'')\n"
+ "#русские и английские буквы не могут быть одновременно\n"
+ "(?: (?![\\s\\S]*[aeiouyAEIOUY]{4}) #no 4 vowel letters sequentially\n"
+ " (?![\\s\\S]*[bcdfghjklmnpqrstvwxzBCDFGHJKLMNPQRSTVWXZ]{5}) #no 5 consonant letters sequentially\n"
+ " (?:[a-zA-Z\\p{Pd}’']|(?![\\r\\n])\\s)+\n"
+ " | (?![\\s\\S]*?[аеиоуыэюяёАЕИОУЫЭЮЯЁ]{4}) #не может содержать 4 гласных буквы подряд (3 гласных буквы подряд есть в слове 'длинношеее')\n"
+ " (?![\\s\\S]*?[бвгджзклмнпрстфхцчшщйъьБВГДЖЗКЛМНПРСТФХЦЧШЩЙЪЬ]{6}) #не может содержать 6 согласных букв подряд (5 согласных букв подряд есть в фамилии 'Мкртчан')\n"
+ " (?:[а-яёА-ЯЁ\\p{Pd}’']|(?![\\r\\n])\\s)+\n"
+ ")\n"
+ "$";
final String string = "Ииии\n"
+ "Нннннн\n"
+ "Ttttt\n"
+ "Uuuu\n"
+ "АлисаTab \n"
+ "Алиса Tab\n"
+ "Иван'\n"
+ "-Alex\n"
+ "Жан-Клод Ван Дам\n"
+ "Алиса--Виктория\n"
+ "Алиса–Виктория\n"
+ "Алиса—Виктория\n"
+ "Иван Иванович Иванов\n"
+ " Динношееев \n"
+ "Мкртчан\n"
+ "д’Артаньян\n"
+ "Ali Baba\n"
+ "Jhon Smith";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}