import re
regex = re.compile(r"[0-9]{8}_[0-9]{1,6}", flags=re.MULTILINE)
test_str = ("20101112_131415\n"
"20101112_1314\n"
"20101112_13\n"
"20101112_1\n"
"20202212_99")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")