re = /{\K\d+(?:\.\d+)?(?=[^{}]*})/m
str = '{ {{7.718 1072.463} {7.718 1230.985} {15.724 1230.985} {15.724 1198.742} {15.759 1198.742} } {{7.702 1072.489} {7.702 889.858} {13.418 889.858} {13.418 887.367} {13.435 887.367} {13.435 887.376} {7.144 887.376} } }
{7.718 1072.463}
{7.718 1072.463'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end