$re = '/^[A-Z0-9-]*$/im';
$str = 'abc034
Abc-045
ewrrerer%
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);