#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(02|03|04|06|08|09|072|074|076|077|078|079|050|051|052|053|054|055|056|058|059)((?:(?![1,0]{1}))\d{7})$"
Local $sString = "Valid: " & @CRLF & _
"022345677" & @CRLF & _
"032345677" & @CRLF & _
"042345677" & @CRLF & _
"062345677" & @CRLF & _
"082345677" & @CRLF & _
"092345677" & @CRLF & _
"0722345677" & @CRLF & _
"022345677" & @CRLF & _
"0742345677" & @CRLF & _
"0762345677" & @CRLF & _
"0742345677" & @CRLF & _
"0762345677" & @CRLF & _
"0772345677" & @CRLF & _
"0782345677" & @CRLF & _
"0792345677" & @CRLF & _
"0502345677" & @CRLF & _
"0512345677" & @CRLF & _
"0522345677" & @CRLF & _
"0532345677" & @CRLF & _
"0542345677" & @CRLF & _
"0552345677" & @CRLF & _
"0562345677" & @CRLF & _
"0582345677" & @CRLF & _
"0592345677" & @CRLF & _
"" & @CRLF & _
"NotValid : " & @CRLF & _
"021345677" & @CRLF & _
"030345677" & @CRLF & _
"142345677" & @CRLF & _
"362345677" & @CRLF & _
"282345677" & @CRLF & _
"492345677" & @CRLF & _
"5722345677" & @CRLF & _
"622345677" & @CRLF & _
"7742345677" & @CRLF & _
"8762345677" & @CRLF & _
"9742345677" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")