# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^0(?:[234689]|5[0-689]|7[246789])(?![01])(\d{7})$"
test_str = ("Valid: \n"
"022345677\n"
"032345677\n"
"042345677\n"
"062345677\n"
"082345677\n"
"092345677\n"
"0722345677\n"
"022345677\n"
"0742345677\n"
"0762345677\n"
"0742345677\n"
"0762345677\n"
"0772345677\n"
"0782345677\n"
"0792345677\n"
"0502345677\n"
"0512345677\n"
"0522345677\n"
"0532345677\n"
"0542345677\n"
"0552345677\n"
"0562345677\n"
"0582345677\n"
"0592345677\n\n"
"NotValid : \n"
"021345677\n"
"030345677\n"
"142345677\n"
"362345677\n"
"282345677\n"
"492345677\n"
"5722345677\n"
"622345677\n"
"7742345677\n"
"8762345677\n"
"9742345677\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.