package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<formula>[A-Za-z0-9]\w+)(?<charge>[+-\s]*)(\((?<state>[^\)]*)\))?`)
var str = `HBr-(g)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}