$re = '/(?:(\w+)|\G(?!^))\h+<([^<>]+)>/m';
$str = 'test <1> <example> <dynamic>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);