$re = '/^[a-zA-Z0-9_.]{1,64}$/';
$str = 'asdv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);