using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"hello.*?(?<!here end)\.";
string input = @"XXXX@gxxl.com. this will share the costs and hello you the initial here end. must be carrefully done.Keep going.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}