using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(([^()]*)\)(?=(?:[^()]*\)){2})";
string substitution = @"{$1}";
string input = @"(aaa) (ee (ff (gg))) (bbb (ccc (eee))) ddd";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}