package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^@]+`)
var str = `Domain\username@abc.com
Domain\username`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}