// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)NOTE\=\"\w+\d:(?<field1>\d+),(?<field2>\d+)[^;]+;\w+\d:(?<field3>\d+),(?<field4>\d+).*?DEL:\s+(?<field5>\d+),(?<field6>[^;]*;)DEL:\s+(?<field7>\d+),(?<field8>[^;]*);"#).unwrap();
let string = "2022-11-09 17:36:05 BANK_CITAD_ID=\"79303001\", SOTIEN_CONLAI=\"150000000\", UPDATED_DATE=\"2022-11-09 17:36:05.0\", FILE_NAME=\"GTCG_dinhky_20221109.xlsx\", STATUS=\"DATA_ERROR\", ERROR_MSG=\"NOT_ALLOW_LIMIT\", SOTIENTANG=\"0\", SOTIENGIAM=\"0\", LOAI_FILE=\"DK\", STT=\"2\", BANK_CODE=\"STB\", ID=\"6829\", NOTE=\"DC1:2286754104070,1,10/11/2022 00:00:00;DC2:10000000000,1501000000,10/11/2022 00:00:00,1000001;DEL: 1501000001,10/11/2022 00:00:00;DEL: 1501000001,10/11/2022 00:00:00;\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}