re = /(?:^([0-9A-Za-z])\1\1(?=.*\1{6}$)|([0-9A-Za-z])\2{5}(?<=^\2{3}.*)$)/m
str = 'BBB i love regex BBBBBB'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end