package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^ OF $`)
var str = `OF
OF
of
text with of in text
of course
fo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}