package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bone\b`)
var str = `One: This is one and two and someone three.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}