import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(object)|(: .*)|(end)|(?! On)( .*)";
final String string = "object field: TMemo\n"
+ " Left = 6\n"
+ " Top = 23\n"
+ " Width = 390\n"
+ " Height = 156\n"
+ " Anchors = [akLeft, akTop, akRight, akBottom]\n"
+ " ScrollBars = ssVertical\n"
+ " TabOrder = 1\n"
+ " OnChange = fieldChange\n"
+ " OnKeyUp = fieldKeyUp\n"
+ " AddMenu = True\n"
+ " RightClickMoveCaret = True\n"
+ " RightEdge = 0\n"
+ "end\n\n"
+ "object btn: TButton\n"
+ " Left = 5\n"
+ " Top = 3\n"
+ " Width = 89\n"
+ " Height = 21\n"
+ " Caption = 'Button'\n"
+ " TabOrder = 0\n"
+ " TabStop = False\n"
+ " OnClick = btnClick\n"
+ "end";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}