import re
regex = re.compile(r"\w[\w-]*(?:\.\w[\w-]*)*@\w+\.(?:com|miami)", flags=re.MULTILINE)
test_str = ("Jazmine Holcomb 3212 Adams Avenue Washington MD eluir.azevedo.7o@lucidmode.com\n"
"Sofie Hagan 4241 Jerry Dove Drive Erie PA zfraction00t@jfaccupuncture.com\n"
"Cairo Tyson 3768 Clifford Street San_Jose CA varifi.amin@disabilitylawyersatlanta.com\n"
"Tasmin Kearney 2956 Adams Drive El_Campo CA 1paul.clinssonq@aprilmovo.com\n"
"Aydin Moran 3727 Sarah Drive Lake_Charles LA 3egdol@blogspot.miami\n"
"Samirah Pollard 946 Douglas Dairy Road Prosperity SC rzekohahaha@gmailup.com\n"
"Jaskaran Wheeler 1521 Richards Avenue Torrance CA ardit.ditty@netfacc.com\n"
"Gerrard Browning 4690 Felosa Drive Los_Angeles CA cgbeshar@lotomoneymaker.com\n"
"Haleema Craft 73 Pinchalone Street Norfolk VA 0kjhdsxz123e@summitgg.com\n"
"Brett Neal 4079 Johnson Street Garner NC fali_gx2000w@plussmail.com")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")