#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s.*,"
Local $sString = "Jose Jose Ricardo, lopez de montana."
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)